Die letzten Haushaltstipps: Möbel im Internet kaufen · Test:microSDHC 16GB Class10-Spei* · Re: Neue Leuchten für meine Wohn* · Re: Welches Betriebssystem benut* · Re: Kann mir jemand ein gutes Sc* · Re: Rezept: Spargelsalat · welchen betriebssystem benutzt i* · Neue Leuchten für meine Wohnung* · Re: mikrofasersofa reinigen · Re: Babyöl für weiche Haut

Die letzten Themen im Schnellsuche-Forum: Stromvergleich im Internet: Dies* · Re: Was fahrt ihr für ein Auto?* · Was fahrt ihr für ein Auto? · Musik Video · Re: Neue User · Re: Zensur im Internet · Neue User · Jetzt unterschreiben: Stoppt die* · .ausgestrahlt-Newsletter 04.05.2* · TTIP: Demo + Petition dagegen

HowTo: Problem: CoolURI mit datamints_feuser

HowTo: Problem: CoolURI mit datamints_feuser

Beitragvon schnellie » Donnerstag 31. Dezember 2009, 14:59

datamints_feuser (datamintsfeuser, tx_datamintsfeuser_pi) und Probleme bei der Registrierung (TYPO3) wenn CoolURI oder RealURL benutzt werden

Dieses Mini-HowTo ist (wie fast alles) nur eine Gedankenstütze für mich :-) Aber jeder der etwas dazu bei zu tragen hat, darf sich sehr gerne melden!

Problem:
Ich benutze Typo3, CoolURI (NICHT CoolURL!) und datamints_feuser (in der Version 0.2.2)...

Problembeschreibung:
Beim Anlegen neuer User mit der Option "Registration double-opt-in" funktioniert CoolURI nicht richtig. Ich bekomme z.B. folgende URI in der Mail mit geteilt:

{DESCRIPTION}

Darauf hin bekomme ich nur einen 404-Error vom Server zurück (Datei nicht gefunden)...

Problem erkannt:
Das liegt daran, das der erste "Get-Parameter" mit einem & (und) und nicht mit einem ? (Fragezeichen) beginnt.

Problemlösung:
In der Datei: typo3conf/ext/datamints_feuser/pi1/class.tx_datamintsfeuser_pi1.php

musst Du folgende Zeile (bei mir in der Version 0.2.2 in Zeile Nummer 289) leicht abändern:
{USERNAME} {L_WROTE}:$pageLink = (strpos($this->pi_getPageLink($GLOBALS['TSFE']->id), '?') !== false) ? $this->pi_getPageLink($GLOBALS['TSFE']->id) . '?' : $this->pi_getPageLink($GLOBALS['TSFE']->id) . '&';


{USERNAME} {L_WROTE}:$pageLink = (strpos($this->pi_getPageLink($GLOBALS['TSFE']->id), '?') !== false) ? $this->pi_getPageLink($GLOBALS['TSFE']->id) . '?' : $this->pi_getPageLink($GLOBALS['TSFE']->id) . '?';


Das sollte auch mit RealURL funktionieren...

Es gibt (soweit ich es im Kopf habe) auch die Möglichkeit es direkt in der .htaccess anzupassen. Aber da ich keine Zeit und Lust habe, mich mal wieder mit modrewrite rum zu plagen, hilft diese Lösung bis zum nächsten Update ;-)
Liebe Grüße
Thorsten alias Schnellie...


Benutzeravatar
schnellie
Super-Moderator
Super-Moderator
 
Beiträge: 1418
Registriert: Montag 19. August 2002, 19:38
Wohnort: Hamburg

Advertisement

Zurück zu Tutorials, Anleitungen, HowTo's, FAQs

 


  • { RELATED_TOPICS }
    Antworten
    Zugriffe
    Letzter Beitrag

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron

Setze ein Bookmark bei: Google  yahoo  slashdot.org  Delicious.com  Digg.com  Linksilo.de  favit.de  Favoriten.de  Linkarena.com  icio.de  Fuzz  Nuouz  Reddit  Scoopeo  Wikio  addThis

Powered by Schnellsuche.de and Kannchen.de - IMPRESSUM